Back to overview
Degraded

Download Issues in the Russian Federation

May 20 at 10:45am CEST
Affected services
File Server

Resolved
May 20 at 02:47pm CEST

After checking internally, it appears that the traffic to our upstream provider is being actively blocked by the Russian government. We do not have any influence over this. We recommend affected users to reach out to their internet provider for more information or use VPNs to continue downloading.

Created
May 20 at 10:45am CEST

We are aware of reports from users in the Russian Federation experiencing difficulties when attempting to download files. Our engineering team is actively investigating the issue. In the meantime, we recommend using a VPN as a temporary workaround to continue downloading.