Back to overview
Degraded
Website Performance Degraded
May 14 at 10:29pm CEST
Affected services
Homepage
Resolved
May 18 at 09:01pm CEST
Performance has improved, but we will continue to implement further upgrades over time.
Affected services
Homepage
Created
May 14 at 10:29pm CEST
We are well aware of the degraded performance of the site. The teams are already working to scale resources and improve overall reliability and performance. We ask for your patience.
Affected services
Homepage