Back to overview
Degraded
Store: Issues with PayPal Payments
May 14 at 10:28pm CEST
Affected services
Homepage
Resolved
May 16 at 03:13pm CEST
PayPal payments should be back to normal now.
Affected services
Homepage
Created
May 14 at 10:28pm CEST
PayPal payments are currently unavailable in the EEA. We kindly ask users to use an alternative payment method, such as credit card, to complete their Store or Premium purchases until further notice. This is already being addressed by our payment partner and PayPal.
If you placed an order using PayPal, your order has been placed on a refund list. We will refund the failed transactions to your PayPal account as soon as possible.
Affected services
Homepage