Back to overview
Degraded

Email Delivery / Signup / Password Reset is unavailable

Jan 25 at 12:05pm CET
Affected services
Homepage

Resolved
Jan 25 at 12:22pm CET

The issue with our upstream provider has been resolved.

Created
Jan 25 at 12:05pm CET

Our upstream provider for Email delivery is currently having a major outtage. Site functions such as Sign-Up or Password-Reset are therefore currently disabled and not working. The team stays in close contact with our upstream provider to solve this issue as fast as possible.