Back to overview
Degraded

Downloads degraded

Dec 30 at 02:39pm CET

Resolved
Dec 30 at 05:21pm CET

Services are restored.

Updated
Dec 30 at 04:04pm CET

While the root cause has been identified, some servers are still struggling to boot up. Traffic is therefore rerouted to a small set of servers, unfortunately download speeds are still very slow. We kindly ask you to not download any files at the moment while the problem persists.

Updated
Dec 30 at 03:21pm CET

We have identified the root cause of the issue. Services are slowly restarting and recovering.

Created
Dec 30 at 02:39pm CET

We are seeing a sharp increase in download traffic. Our servers are currently overloaded and try to serve every download. New downloads are therefore delayed and deactivated until enough resources are available again.