Back to overview
Degraded
Degraded Performance
Oct 23 at 05:41pm CEST
Affected services
Homepage
Resolved
Oct 23 at 06:57pm CEST
The maintenance is scheduled.
Affected services
Homepage
Created
Oct 23 at 05:41pm CEST
We are aware of degraded website performance, which is affecting the website speed and overall loading times of the platform. Our team has scheduled updates to our backend for the coming week to address these issues. We are very sorry for the inconvenience.
Affected services
Homepage